Inhaltsverzeichniss

Einführung: 4

Die Firmen Wöhwa.. 4

Produkte Wöhwa Waagenbau.. 4

Produkte Wöhwa Gyroskop. 4

Vorstellung des Programmes „Gyro-Data“. 4

Anschluß an verschiedenen Waagen.. 4

Vorgehensweise bei der Erstinstallation des Programmes. 5

Merkmale von Gyro-Data.. 5

Allgemeines: 6

Allgemeines über die Dateien. 6

Installation.. 6

Rechner und Peripheriegeräte.. 6

Der Rechner.. 7

Bildschirm.. 7

Drucker.. 7

Maus. 7

Tastatur (Programm kann weitgehend ohne Maus bedient werden) 7

Editieren von Daten.. 7

Das Hauptmenü. 9

Allgemeines zu den Stammdaten. 10

Was sind Stammdaten.. 10

Datensuche mit einem Suchbegriff. 10

Kundendatei 12

Übergabe der Anschrift an z. B. Word. 12

Maske Kundendatei. 12

Beschreibung der Steuerfelder.. 12

Beschreibung der Felder der Kundendatei 13

Baustellendatei 15

Felder der Baustellendatei. 15

Materialdatei 17

Felder der Materialdatei. 17

Kraftfahrzeugdatei 19

Felder der Fahrzeugdatei. 19

Kartendatei: 22

Funktion und Aufbau. 22

Beispiel: 23

Eingabe: 23

Parameterdatei 25

Felder der Parameterdatei: 25

Mat-LS-Kreis (Unterpunkt Parameterdatei) 27

Felder der Mat-LS-Kreis. 27

Wiegebetrieb. 29

Ablauf Wiegebetrieb.. 29

Taraverwiegung.. 29

Bruttoverwiegung.. 30

Lieferscheinerstellung.. 30

Vorgehensweise bei noch nicht erfaßten Stammdaten: 32

Regeln für die Eingabe der Kartennummer.. 32

Hofliste. 33

Funktion: 33

Hofliste löschen.. 33

Lieferscheindatei 34

Korrektur der Lieferscheine.. 34

Drucken: 35

Lieferscheindruck.. 35

Statistikdruck.. 35

Auswahl Statistikdruck.. 35

Materialstatistik.. 37

Stammdatensicherung. 37

Lieferscheine. 37

Allgemeines. 37

Notwendige Einstellungen. 37

Lieferscheine an Faktura. 38

Übertragung auf Diskette. 38

Übertragung per DFÜ.. 38

Datensicherheit für die Übertragung. 38

Lieferscheinformular einstellen. 38

Maske für die Einstellung des Lieferscheinformulares. 39

Beispiel 1: Neuanlage eines freien Textes. 39

Beispiel 2: Verschieben der Kundennummer . 40

Protokolle des eichfähigen Speichers ansehen (Option) 40

DFÜ (Datenfernübertragung) 41

Hardware: 41

Analoge Modems. 41

ISDN.. 41

Software.. 41

Dateien übertragen. 41

Fernsteuerung (Fernwartung) 41

Sicherheit. 41

Aufbau der Lieferscheindatei 42

Ergänzende Beschreibung für GyroData. 43

Neuinstallation.. 43

Mehrfachinstallation: 43

Waagenprogramm (Datenserver) 43

Arbeitsplatz zur Stammdatenpflege (Büro) 43

Parametrierung der Schnittstellen: 44

Einstellung für Windowsdrucker.. 45

Optionen für GyroData.. 46

Kundenspezifische Ergängzungen: 46

Einführung:

Die Firmen Wöhwa

WÖHWA GYROSKOP ist das Systemhaus von WÖHWA und wurde 1978 gegründet. Hier werden Hard- und Software zur Integration von Automatisierungsanlagen entwickelt und gefertigt. In unserer Fabrik für die elektronische Kraftmessung mit modernen und großzügigen Produkträumen wird außerdem die gesamte elektronische Ausstattung für die hochtechnisierten Kraftmeßsysteme – von der Kreiselmeßzelle bis zur kompletten Datenerfassung und –verarbeitung – entwickelt und gefertigt.

WÖHWA WAAGENBAU wurde von Josef Wöhrl 1949 gegründet. Modernste Einrichtungen und Maschinen garantieren höchste Präzision und Qualität unter wirtschaftlichen Aspekten.

Das Produktionsprogramm beider Firmen im Überblick:

Produkte Wöhwa Waagenbau

Maßgeschneiderte Problemlösungen für

- die industrielle Wägetechnik

- Straßenfahrzeug-Waagen

- Gleisfahrzeug-Waagen

- Förderband-Waagen

- Dosierband-Waagen

- Dosiergeräte und Systeme für

- Schüttgüter aller Art

Produkte Wöhwa Gyroskop

Digitale Wägeanlagen mit Kreiselmeßzellen oder Meßzellen

- Entwicklung und Fertigung von Hard-und Software zur Integration von Automatisierungsanlagen

- Farbgrafische Computer-Systeme zur Steuerung von Aufbereitungsanlagen

- Dosiersteuerungen

- Werksteuerungen

- Automatische Verwiege- und Verladeanlagen

- Fakturierung

Vorstellung des Programmes „Gyro-Data“

Mit dem vorliegenden Programm zur Wägedatenverarbeitung wird die Erstellunng von Lieferscheinen und damit die Abfertigung der Fahrzeuge auf der Waage entscheidend beschleunigt.

Durch Bedienungsvereinfachung, Einführung einer „Kartendatei“ und mittels der Programmfunktion „Hofliste“ wird der Wiegemeister in die Lage versetzt, den Wiegeschein mit wenigen Eingaben am Bildschirm komplett auszufüllen und auszudrucken.

Innerhalb des Programmsystems werden dem Bediener alle erforderlichen Schritte angezeigt. Die Auswahl des nächsten Verarbeitungsprogramms erfolgt durch Menüs. In der Fußleiste wird angezeigt, welche Tasten freigegeben sind und welchen Verarbeitungsschritt diese bewirken.

Anschluß an verschiedenen Waagen

- eine Fahrzeugwaage

- zwei Fahrzeugwaagen

- eine Fahrzeugwaage und eine Bandwaage

- eine Bandwaage

- zwei Bandwaagen

- eine Verbundwaage

zum Anschluß an WÖHWA-Wägeterminal GCU 45, GCU-64, Radlader oder GCU20.

Anbindung an bauseitige Wägeterminals auf Anfrage.

Mit dem Programm Gyro-Data wird die Erstellung von Lieferscheinen und damit die Abfertigung der Fahrzeuge auf der Waage entscheidend beschleunigt.

Vorgehensweise bei der Erstinstallation des Programmes

Arbeitsschritte

1. Anlegen der Kundendatei

2. Anlegen der Baustellendatei

3. Erfassung der Kraftfahrzeuge

4. Erfassung des Materials

5. Anlegen der Kartendatei

6. Festlegung der Parameter

Beim Anlegen der oben aufgeführten Dateien handelt es sich um sog. Stammdaten. Die Kartendatei ist das Kernstück des Programms GYRO-DATA. Im Wiegebetrieb ist sie eine der wertvollsten Hilfsmittel und dient einer schnellen und rationellen Abfertigung der Fahrzeuge, indem häufig wiederkehrende Daten auf Knopfdruck für die Lieferscheinerstellung zur Verfügung gestellt werden.

Merkmale von Gyro-Data

Ø Netzwerkfähigkeit, d. h. es können mehrere Programme gleichzeitig auf die Dateien zugreifen (z. B. 1 Arbeitsplatz für Stammdatenpflege und ein Wiegeplatz), Ein- und Ausgangsverwiegung über getrennte Waagen.

Ø Beim Anschluß einer Bandwaage kann das Zählwerk über eine Funktionstaste gelöscht werden.

Ø Protokolldruck für Lieferscheindruck, Tara- und Bruttowägung, alternativ eichfähiger Speicher im Waagenprogramm eingebaut. (In Verbindung mit Wöhwa Waagenanzeige)

Ø Kunde, Baustelle und Material können als Zwangsfelder definiert werden, d. h. es muß eine Eingabe erfolgen, bevor das Feld verlassen werden kann.

Ø Definitionsmöglichkeit, ob kundenbezogene Baustellen oder nicht.

Ø Bei Verwendung der WÖHWA-Fakturierung, müssen die Baustellen kundenbezogen sein mit 3-stelliger Baustellennummer (999 Baustellen je Kunden möglich), 6-stelliger Kundennummer (insgesamt also 9 Stellen) und 4-stelliger Materialnummer,

Ø Festlegung der Feldlängen für Kundennummer, Baustellennummer und Materialnummer, wahlweise von 2 bis 15 Stellen (unter Berücksichtigung der Einschränkungen für unsere Fakturierung).

Ø 4 – 10stellige Lieferscheinnummer

Ø WIEGEGEBÜHREN können über Steuerung der Materialnummer bestimmt werden. Wiegegebühren als Barverkauf und normaler Lieferscheinausdruck möglich.

Ø Im Wiegebetrieb Auswahl Barverkauf über Karte BAR. Diverse Kundennummern für Barverkauf, Einmalkunde und Einmalkarte werden in der Parameterdatei hinterlegt.

Ø Anlegen neuer Kunden und Baustellen während des Verwiegevorgangs.

Ø Lieferscheine an Fakturierung erzeugt eine ASCII-Datei und eine DBF-Datei, für die Übergabe zur Fakturierung (z. B. Fakturierprogramm EXAKT).

Ø Freie Gestaltung 3er unterschiedlicher Lieferscheinformulare – 3 LS-Nummernkreise

Ø Automatische Erstellung zahlreicher Statistiken.

Ø Ausdruck von Statistiken und Stammdaten wahlweise auf Bildschirm oder Drucker.

Ø Beliebige Wiederholung des Lieferscheinausdrucks unmittelbar nach dem Ausdruck, z. B. bei Papierstau.

Ø Wahlweise Lieferscheindruck über Laserdrucker oder Nadeldrucker.

Ø Nachträgliche Automatisierung des Wiegebetriebs über Kartenleser möglich.

Ø Anbindung an WÖHWA-Dosiersteuerung PCS 35, um Fehler bei der Lieferscheinerstellung, wie z. B. falsche Materialanwahl, zu verhindern.

Ø Läuft unter verschiedenen Auflösungen (640 x 480 – 1024 x 768) maximiert. (Windows kleine Schriften)

Ø Optional integrierter eichfähiger Speicher.

Allgemeines:

Allgemeines über die Dateien.

Das Programm benötigt unterschiedliche Dateien, die hier nur ganz kurz erwähnt werden. Dateien mit der Endung .dll enthalten Funktionen, welche vom Waagenprogramm benötigt werden. Diese Dateien müssen im Unterverzeichnis der Waage sein, und dürfen nicht ins System von Windows kopiert werden. Bei einem Update müssen diese Dateien ersetzt werden. Die Datei waage.exe enthält das Programm. Bei Programmänderungen wird diese Datei ersetzt. Eine Sicherung dieser Datei sollte immer vorhanden sein. Die Dateien mit der Endung .dbf sind die Datendateien. Diese Dateien (dBASE IV) enthalten die Stammdaten. Regelmäßige Sicherung der Stammdaten ist notwendig, um bei einem Defekt des Rechners diese Daten auf ein neues System kopieren zu können. Dateien mit der Endung .ntx sind Schlüsseldateien für die Stammdaten. Diese Dateien können durch den Befehl „Dateien reindizieren“ vom Programm erzeugt bzw. neu aufgebaut werden. Bei Fehlern im Dateisystem ist immer ein „Dateien reindizieren“ vom Programm aus zu starten.

Installation

Falls Sie das komplette Programm von CD auf die Festplatte kopieren, müssen Sie die unter Umständen den Schreibschutz an den Dateien entfernen. Im Unterverzeichnis des Waagenprogrammes (meist c:\waage) geben Sie folgenden Befehl ein: attrib –r *.* RETURN. Anschließend kann dann auf die Dateien zugegriffen werden. Achtung: Alle dll-Dateien müssen ins Unterverzeichnis der Waage kopiert werden. Es dürfen keine Dateien ins Verzeichnis von Windows kopiert werden. Einträge in die Windowsregistrierung sind nicht erforderlich. Das Waagenprogram entfernt den Schreibschutz an den Dateien automatisch.

Rechner und Peripheriegeräte

Der WÖHWA-PC besteht aus der Systemeinheit (=Rechner), der Tastatur, dem Bildschirm (=Monitor) und einem Drucker und Maus.

IBM kopatibler PC mit Windows 2000/XP, jeweils Prozessor mit MMX-Unterstützung, und mind. 128MB Arbeitsspeicher. Einstellung auf 800x600 oder 1024x768 Bildpunkten.

Wir empfehlen unseren Kunden, sich mit den einführenden Kapiteln im Windows-Betriebssystem vertraut zu machen, um die erforderlichen Grundkenntnisse über die Arbeit mit dem PC zu erlangen. Das Bedienpersonal muß Grundkenntnisse über das Betriebssystem haben.

Das Programm läuft auf einem IBM kompatiblen PC und Netzwerkkarte und/oder DFÜ-Verbindung je nach Anwendung. mind. eine freie serielle Schnittstelle (COM1 oder COM2) muß für die Anbindung an der Waage zur Verfügung stehen. Teilweise sind mehrere Schnittstellen notwendig. Ebenso muß mind. eine parallele Schnittstelle für den Lieferscheindrucker zur Verfügung stehen. Der Lieferschein wird bei Nadeldruckern direkt auf LPT1 (DOS-Modus) ausgegeben. Mit Windowstreibern ist die Druckqualität bei Nadeldruckern teilweise nicht so gut. Für Statistiken könnte auch ein Laser- oder Tintenstrahldrucker an einem 2. Druckerport (oder Netzwerk) angeschlossen sein. Bei Freigabenamen im Netzwerk dürfen diese keine Leerzeichen und Sonderzeichen enthalten und nicht länger als 15 Zeichen sein. Aufgrund der Vielzahl von Betriebssystemvarianten (SP) und div. Treibervarianten kann es durchaus vorkommen, daß das Programm auf einem PC nicht richtig läuft. In diesem Fall muß dann auf einen anderen PC zurückgegriffen werden, was bisher allerdings noch nicht der Fall war.

Falls notwendig kann die Waage auch über einen Ethernet-Schnittstellenwandler oder über einen USB-Schnittstellenwandler angeschlossen werden. In diesem Fall ist dann nur ein Netzwerkanschluss bzw. USB-Anschluss notwendig, eine serielle Schnittstelle kann dann entfallen. Beide Geräte sind zusätzliche Optionen, und im Standard nicht enthalten.

Der Rechner

Bildschirm

Der mitgelieferte Farbbildschirm ist ein mind. 17“ hochauflösender Farbmonitor, mit einer möglichen Auflösung von 800x600 oder 1027x768. Wir empfehlen einen 17“ TFT - Monitor mit einer Auflösung von 1024x768.

Drucker

Der Drucker ist ein IBM/EPSON-kompatibler 9-Nadel-Drucker mit Schönschrift (Near Letter Quality). Der Drucker wird von WÖHWA betriebsbereit konfiguriert. Die eingestellten Standardwerte sollten nicht verändert werden.

Mit dem Drucker wird ein ausführliches Handbuch ausgeliefert, aus dem alle Einzelheiten über Betrieb, Wartung und Austausch von Farbbändern ersichtlich sind.

Maus

Mit der Maus können die Schaltknöpfe ebenfalls bedient werden (linke Maustaste). Das Programm läßt sich auch weitgehend ohne die Maus bedienen.

Tastatur (Programm kann weitgehend ohne Maus bedient werden)

Umgang mit der Tastatur entnehmen Sie bitte dem Windowshandbuch. Folgende Funktionstasten werden vom Programm standardmäßig benutzt.

F2 Umschaltung auf Handeingabe im Wiegebetrieb

F6 Umschaltung zwischen Lieferschein-, Tara- oder Bruttowägungs-Modus

F9 Anzeige der Daten in Listenform

Editieren von Daten

Rückschritttaste

Löscht das Zeichen links neben dem Cursor

Einfg

Schaltet den Einfügemodus ein/aus

Im ersten oder letzten Feld der Maske bewirkt Pfeil hoch bzw. Pfeil runter den Abschluß der Eingabe; ansonsten kann die Eingabe nach dem Eintrag im letzten Feld mit Enter beenden, was mit folgender Meldung in der Fußzeile des Bildschirms quittiert wird:

Korrekt X = Neueingabe

Die Meldung „Korrekt“ ist markiert. Wenn Sie mit Ihrem Eintrag zufrieden sind, betätigen Sie Entertaste oder linke Maustaste. Die Auswahlfunktionen lassen sich aber auch über den Anfangsbuchstaben, in diesen beiden Fällen also mit „k“ oder „x“, anwählen. Zwischen den beiden Feldern können Sie mittels der Pfeiltaste wechseln.

Wenn Sie nur eine Kleinigkeit zu ändern haben, sollten Sie Ihren Eintrag trotzdem als korrekt bestätigen, denn so werden die eingegebenen Daten abgespeichert. Zur Korrektur können Sie den abgespeicherten Datensatz anschließend durch die Eingabe der Kundennummer (in der Kundendatei), Baustellennummer (in der Baustellendatei), Kfz.-Nr. (in der Kraftfahrzeugdatei) und Materialnummer (in der Materialdatei) nochmals aufrufen. Wenn Sie „x“ für Neueingabe wählen, wird der Bildschirminhalt gelöscht und für eine Neueingabe freigegeben.

Nach der Abspeicherung mit „Korrekt“ erscheint die leere Bildschirmmaske für weitere Eingaben.

Wenn Sie den zuletzt abgespeicherten Datensatz noch einmal aufrufen wollen, tippen Sie die Kundennummer (in der Kundendatei),Baustellennummer (in der Baustellendatei), Kfz-Nr. (in der Kraftfahrzeugdatei) oder Materialnummer (in der Materialdatei) nochmals ein und beenden die Eingabe mit „Enter“. Statt der Kundennummer können Sie auch den Matchcode (in der Kundendatei), KFZ-Kennzeichen (in der Kraftfahrzeugdatei), oder Materialbezeichnung1 (in der Materialdatei) eingeben. Der angewählte Datensatz erscheint erneut auf dem Bildschirm mit den unten gezeigten Buttons in der Fußzeile.

Korrigieren Nächster Vorheriger Löschen X=Neueingabe

Die zur Auswahl angebotenen Funktionen können entweder mit dem CURSOR, d. h. mit den Pfeiltasten, angewählt und mit Enter bestätigt werden. Etwas schneller lassen sich die Funktionen durch Eingabe des Anfangsbuchstaben selektieren. Die Funktionen haben folgende Bedeutung:

K = Korrigieren:

Umschalten in die Betriebsart „Datensatz ändern“.

V = Vorheriger:

Rückwärts blättern, d. h. der Datensatz, der in der Datei vor dem angezeigten steht, kommt zur Anzeige.

N = Nächster:

Vorwärts blättern, d. h. der Datensatz, der in der Datei nach dem angezeigten steht, kommt zur Anzeige.

L = Löschen:

Datensatz löschen. Vorher wird zur Sicherheit noch einmal abgefragt, damit Datensätze nicht versehentlich gelöscht werden. Wählt man in der Sicherheitsabfrage „Widerrufen“, bleibt der Datensatz erhalten.

X = Neueingabe:

Ein neuer Datensatz kann eingegeben werden oder ein bereits abgespeicherter erneut aufgerufen werden. Mit ESC gelangt man zum Hauptmenü zurück. Mit F9 wird die Liste der Datensätze angezeigt

Taste F9:

Die Liste der vorhandenen Datensätze wird in einem Bildschirmfenster angezeigt. Mit Pfeil runter, Pfeil hoch, Bild auf, Bild ab können Datensätze angewählt werden, wobei der mit dem Leuchtbalken markierte Datensatz mit Enter auf dem Bildschirm geholt werden kann.

Das Hauptmenü

Auswahl der Menüpunkte mittels Maus, oder ALT-Taste + unterstrichener Buchstabe der Menueleiste.

Auswahl der Menü über die Maustaste oder über die Tastatur. Mit z. B. ALT w und anschl. Mit Pfeiltaste auf Wiegebetrieb kann der Wiegebetrieb auch mit der Tastatur gewählt werden. Die unterstrichenen Buchstaben sind für die Auswahl der Menüs in Verbindung mit der ALT-Taste.

Allgemeines zu den Stammdaten

Was sind Stammdaten

Stammdaten sind Daten, die sich sehr selten oder fast nie ändern und häufig benötigt werden, wie z. B. Kundenanschriften, Kfz-Daten, Baustellen, Materialien, etc. Alle diese Daten werden als Datensätze in den sog. Stammdatendateien abgelegt. Ein Datensatz besteht aus mehreren Informationsfeldern und entspricht einer Karteikarte mit Informationen an bestimmten Stellen (=Feldern). Es werden sozusagen elektronische Karteikarten in verschiedenen elektronischen Karteikästen für Kunden, Baustellen, usw., angelegt.

Stammdaten können bei Bedarf jederzeit gesucht und benutzt werden. Das lästige Blättern in einer herkömmlichen Kartei bei der Suche nach bestimmten Informationen wird vom Computer in Sekundenschnelle erledigt.

Die Stammdaten im Programm „GYRO-DATA“ sind die folgenden:

- Kunden

- Baustellen

- Kraftfahrzeuge

- Material

- Karten

- Parameter

Datensuche mit einem Suchbegriff

Die Suche nach einem Stammdatensatz erfolgt in der Regel mit Hilfe eines Suchschlüssels bzw. Suchbegriffs. So ein Schlüssel kann „eindeutig“ oder „mehrfach“ sein. Man spricht von einem eindeutigen Schlüssel, wenn dieser Schlüssel in jedem Datensatz ein anderer ist. Zum Beispiel erhält jeder Kunde eine Kundennummer, die für jeden Kunden nur einmal vergeben wird. Eine Kundennummer kann also nicht zweimal vorkommen. Sucht man z. B in der Kundendatei nach dem Kunden mit der Nummer 25, findet man immer denselben Datensatz vor.

Wenn man die Kundennummer nicht genau kennt, aber weiß, daß sie größer ist als eine bestimmte Zahl, z. B. 34, ist, schreibt man ins Feld Kundennummer eine 34 und drückt die Taste F9. Am Bildschirm erscheint die Liste der Kunden beginnend mit der Kundennummer 34. Mit den Pfeiltasten kann der gewünschte Datensatz in der Liste angewählt und mit Enter auf den Bildschirm geholt werden.

Ein Mehrfachschlüssel, in der Kunden- und Baustellendatei auch Matchcode genannt, ist ein Suchbegriff (=Wort), der in mehreren Datensätzen vorkommen kann. Z. B. können mehrere Kunden denselben Nachnamen haben (Müller).

Beispiel:

In der Kundendatei sollen 5 Sätze angelegt werden und diese sollen im Feld Name1 folgende Einträge haben:

- 1. Satz: Müller Schotterwerke

- 2. Satz: Müller & Söhne

- 3. Satz: Müller & Co.KG

- 4. Satz: Müller GmbH

- 5. Satz: Bauhof Müller

Bei all diesen Firmennamen gibt es die Buchstabenkombination MÜL. Bei der Eingabe von Daten in Schlüsselfelder werden Kleinbuchstaben automatisch in Großbuchstaben umgewandelt. Schreibt man in das Feld Matchcode der 5 angeführten Datensätze MÜLLER, so haben alle 5 Sätze im Suchbegriff die Kombination MÜL.

Wenn Sie Zugriff auf einen dieser Datensätze nehmen wollen, geben Sie im Feld Matchcode MÜL ein, gefolgt von Enter. Am Bildschirm erscheint der erste von den unter MÜL gespeicherten Datensätzen. Mit Nächster bzw. N können Sie in den Datensätzen weiterblättern.

Wollen Sie eine Liste der gesuchten Datensätze anzeigen, geben Sie im Feld Matchcode MÜL ein und betätigen Sie die Funktionstaste F9. Es erscheint eine Liste aller Sätze, deren Matchcodefeld die ersten 3 Buchstaben MÜL enthält. Mit den Pfeiltasten kann der gewünschte Datensatz in der Liste angewählt und mit Enter auf den Bildschirm geholt werden.

Wichtig:

Bei der Suche mit der Kundennummer sind die Sätze nach aufsteigenden Nummern sortiert, während sie beim Matchcode nach dem Alphabeth sortiert sind.

Die Sätze in alphanumerischen Feldern werden wie folgt sortiert und erscheinen in dieser Reihenfolge in der Listenanzeige:

- Leerstellen

- Ziffern

- Kleinbuchstaben

- Großbuchstaben

Falls Sie keine Kunden mit z. B. M eingegeben haben, so positioniert die Liste automatisch auf den nächsten Kunden, in diesem Beispiel Oberndörfer.

Kundendatei

Übergabe der Anschrift an z. B. Word.

Wählen Sie einen Kunden aus, und drücken Sie die Schaltfläche Z-Ablage. Die Kundeanschrift kann dann z. B. in Word über STRG v an beliebiger Stelle eingefügt werden.

Maske Kundendatei

Beschreibung der Steuerfelder

Geben Sie nun im ersten Feld eine Kundennummer ein. Bei der Eingabe einer neuen Kundennummer erscheint am Bildschirm in der Fußzeile die Meldung

Kein Datensatz vorhanden. Kann eingefügt werden.

Die Meldung bleibt nur für wenige Momente am Bildschirm und wird dann ersetzt durch die Meldung

Einfügen X = Neueingabe

Die Meldung „Einfügen“ ist rot unterlegt und kann mit Enter bestätigt werden. Haben Sie sich bei der Kundennummer vertippt, so können Sie durch Betätigen der Taste X den Bildschirm für eine Neueingabe löschen.

Ist die eingegebene Kundennummer korrekt, wird sie mit der Taste „E“ für Einfügen oder Enter bestätigt. Der CURSOR springt danach in das nächste Feld „MATCHCODE“. Geben Sie die Texte in den Feldern gemäß den nachstehenden Felderläuterungen ein.

Wird eine Kundennummer eingegeben, die zuvor schon als Datensatz abgespeichert wurde, dann wird nach Betätigung der Enter-Taste der abgespeicherte Datensatz auf dem Bildschirm angezeigt.

Beschreibung der Felder der Kundendatei

Kundennummer:

Ist ein 6-stelliges, numerisches Feld und wird als eindeutiger Schlüssel zum schnellen Auffinden eines Datensatzes verwendet. Das Programm schreibt vor jede eingegebene Zahl führende Nullen (aus 34 wird 000034 und aus 101 wird 000101). Bei Eingabe von 00000 wird die nächste freie Kundennummer vorgeschlagen, unter der dann ein neuer Kunde angelegt werden kann.

Matchcode:

Ist ein 15-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann, und wird als Mehrfachschlüssel zum schnellen Auffinden von Datensätzen verwendet. Bei der Eingabe von Daten in Schlüsselfelder werden Kleinbuchstaben automatisch in Großbuchstaben umgewandelt.

Es empfiehlt sich, den einprägsamsten Teil des Kundennamens als Matchcode zu verwenden.

Beispiel:

Der vollständige Kundename lautet „Bauunternehmen Müller & Co.KG“. Als Matchcode könnte man hier „Müller & Co.“oder nur „Müller eingeben.

Weiter Informationen zum Matchcode finden Sie im Kapitel 4 unter Datensuche mit einem Suchbegriff .

Debitorenkennung:

Reserviert für Wöhwa Fakturierung.

Sperrvermerk:

Ist ein 1-stelliges Feld, in welches J für JA oder N für NEIN eingetragen werden kann. Das Feld ist vorgesehen, um Sperrvermerke (wie z. B. für Liefersperren) einzutragen. Sie haben mit dieser Funktion die Möglichkeit bei den Kunden mit schlechter Zahlungsmoral ein „J“ einzutragen, so daß im Wiegebetrieb bei der Leiferscheinerstellung die farbig unterlegte Meldung „Vorsicht, Sperrvermerk gesetzt!“ erscheint. Der Wiegemeister könnte angewiesen werden, nach dieser Meldung bei der Geschäftsleitung nachzufragen, ob z. B. nur gegen Barzahlung geliefert wird, oder ob möglicherweise eine totale Liefersperre für diesen Kunden besteht.

Name1:

Ist ein 25-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann. Hier wird der Name der Firma oder des Firmeninhabers eingetragen (z.B. SCHOTTERWERK STEIN & KIESEL).

Name2:

Ist ein 25-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann. In dieses Feld können zusätzliche, namensbezogene Einträge gemacht werden, wenn z. B. der vollständige Firmenname nicht in das Feld Name1 paßt.

Straße:

Ist ein 25-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann.

Land:

Ist ein 3-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann.

PLZ:

Ist ein 5-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann. Hier wird die Postleitzahl eingetragen.

Ort:

Ist ein 25-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann. Hier wird der Ortsname eingetragen.

Erzeugernummer:

Hier kann die Erzeugernummer für die Anlieferung von kennzeichnungspflichtigem Material eingetragen werden. Dieser Eintrag kann im Wiegebetrieb überschrieben werden, und auf dem Lieferschein ausgedruckt. Ablaufbeschreibung siehe bei Punkt: Materialdatei.

Entsorgernachweissummer:

Ablauf wie bei der Erzeugernummer.

Gesamtmenge pro Tag:

Ist ein 9-stelliges, numerisches Feld mit 6 Vorkomma- und 2 Nachkommastellen. In diesem Feld werden die an diesen Kunden gelieferten Nettomengen (in t) aufaddiert. Die Mengen werden unabhängig von der Materialsorte aufaddiert. Um in diesem Feld die korrekte Tagesmenge zu haben, muß das Feld jeden Abend vor Beendigung des Betriebes auf 0 zurückgesetzt werden. Geschieht dies nicht, wird am mächsten Arbeitstag auf den letzten Wert weiter addiert. Wird das Feld z. B. eine ganze Woche lang nicht auf 0 gesetzt, wird die gesamte Wochenmenge angezeigt. Wie man alle oder einzelne Felder auf 0 setzt, wird im Kapitel Statistikdruck 15 erläutert.

Gesamtmenge pro Monat:

Ist ein 9-stelliges, numerisches Feld, mit 6 Vorkomma- und 2 Nachkommastellen. Dieses Feld funktioniert ähnlich wie das vorstehende und sollte jeden Monat auf 0 zurückgesetzt werden.

Gesamtmenge pro Jahr:

Ist ein 9-stelliges, numerisches Feld mit 6 Vorkomma- und 2 Nachkommastellen. Dieses Feld funktioniert ähnlich wie das zuvorstehende und sollte zu Jahresbeginn auf 0 zurückgesetzt werden.

Informationen zum Korrigieren bzw. Editieren der eingegebenen Daten finden Sie im Kapitel 2 unter Das Editieren von Eingaben innerhalb der Bildschirmmasken.

Außer dem Feld Kundennummer lassen sich alle Felder korrigieren. Die Kundennummer kann nur über die Funktion Löschen eines Satzes gelöscht werden.

Baustellendatei

Felder der Baustellendatei

Baustellennummer:

Ist ein 9-stelliges, numerisches Feld und wird als eindeutiger Schlüssel zum schnellen Auffinden des Datensatzes verwendet. Das Programm schreibt vor jede eingegebene Zahl führende Nullen (aus Kunde mit der Nummer 34 und der Baustellennummer 1 ) wird 000034001. Bei Eingabe von 000 wird die nächste freie Baustellennummer vorgeschlagen.

Matchcode:

Ist ein 15-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann, und wird als Mehrfachschlüssel zum schellen Auffinden von Datensätzen verwendet. Die Verwendung des Feldes ist identisch mit dem gleichnamigen Feld der Kundendatei. Bei der Eingabe von Daten in Schlüsselfelder werden Kleinbuchstaben automatisch in Großbuchstaben umgewandelt.

Baustellenbezeichnung1:

Ist ein 30-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann. Hier wird der Name der Baustelle eingetragen (z. B. Finkenstrasse 5)

Baustellenbezeichnung2:

Ist ein 30-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann. In dieses Feld können zusätzliche Einträge zur Baustellenbezeichnung gemacht werden, wenn z. B. der vollständige Baustellenname nicht in das Feld „Baustellenbezeichnung1“ paßt.

Mat.Nr. (16 Felder):

Sind 4-stellige, numerische Felder, in welche je eine Materialnummer geschrieben werden kann.

Normalerweise werden diese Felder bei der Lieferscheinerstellung im Wiegebetrieb mit den im Lieferschein angegebenen Materialien belegt. Die Felder können jedoch auch vorab für jede Baustelle von Hand eingegeben werden, so daß während des Wiegebetriebes vom Programm lediglich die Menge übernommen wird. Wird an die Baustelle ein Material unter der eingegebenen Materialnummer geliefert, wird die gelieferte Nettomenge in t im nebenstehenden Mengenfeld aufaddiert.

Wurden bereits alle Felder mit Materialnummern belegt, bleiben zusätzlich gelieferte Materialsorten unberücksichtigt, d. h. einmal belegte Felder werden nicht mit anderen Materialsorten überschrieben.

Werden diese Felder von Hand eingegeben, sollte eine Materialnummer (=Materialsorte) in den 10 Feldern nur einmal vorkommen. Wird aus Versehen dieselbe Materialnummmer ein zweites Mal vergeben, so ignoriert das Programm das zweite Feld beim Hochaddieren.

Mengex. (16Felder):

Sind zehn 9-stellige, numerische Felder zur Summierung der ausgelieferten Materialmengen entsprechend den Materialsorten in den jeweiils links davon stehenden Feldern Mat.Nr. Die Felder haben 6 Vor- und 2 Nachkommastellen.

Entsorgungsnummer (16 Felder)

Hier kann die spezifische Entsorgungsnummer für dieses Material von der jeweiligen Baustelle eingegeben werden. Diese Nummer wird der Baustelle – Materialkombination zugeordnet, und dann auch auf dem Lieferschein mit ausgedruckt. (Kleiner Entsorgungsnachweis)

Die folgenden Felder sind identisch mit den Feldern in der Kundenstammdatei:

Erzeugernummer / Nachweiss

Gesamtmenge pro Tag:

Gesamtmenge pro Monat:

Gesamtmenge pro Jahr:

Materialdatei

Felder der Materialdatei

Materialnummer:

Ist ein 4-stelliges, numerisches Feld und wird als eindeutiger Schlüssel zum schnellen Auffinden des Datensatzes verwendet. Das Programm schreibt vor jede eingegebene Zahl führende Nullen (aus 34 wird 0034 und aus 101 wird 0101).

Materialbezeichnung1:

Ist ein 30-stelliges, alphanumerisches Eingabefeld und wird als Mehrfachschlüssel zum schnellen Auffinden von Datensätzen verwendet. Das Feld erlaubt die Eingabe aller Zeichen, wie z. B. RHEINSCHOTTER Typ 34-506. Durch Eingabe RHEIN in dieses Feld, kann der Satz mit der vollständigen Eintragung gefunden werden. Bei der Eingabe von Daten in Schlüsselfelder werden Kleinbuchstaben automatisch in Großbuchstaben umgewandelt.

Materialbezeichnung2:

Ist ein 30-stelliges, alphanumerischer Eingabefeld. In dieses Feld können zusätzliche Eintragungen zur Materialbezeichnung gemacht werden, wie z. B. Gemisch 34-506.

Materialpreis:

Ist ein 7-stelliges Eingabefeld. In dieses Feld kann der Materialpreis in DM/t eingegeben werden. Bei einem Barverkauf greift das Programm auf diesen Preis zurück, um die Rechnung zu erstellen. Die Zahl besteht aus 4 Vor- und 2 Nachkommastellen.

Mengeneinheit

Für Wiegebetrieb muß Leer, Ton oder ton sein. Bei anderen Mengeneinheiten erfolgt keine Abfrage der Waage. Der Wert kann im Wiegebetrieb dann sofort von Hand eingegeben werden.

Spezifisches Gewicht.

Umrechungsfaktor tonnen in cbm (für Schweiz)

Abfallschlüssel:

Wenn hier ein Eintrag erfolgt, so behandelt das Programm dieses Material als Abfallmaterial.Wählen Sieso ein Material im Wiegebetrieb aus, sowerden die Felder für Erzeugernummer und Erzeugernachweißnummer und Transporteuernummer für Sie sichtbar. Diese Felder sind folgendermaßen vorbelegt, und können von Ihnen überschrieben werden. Falls Werte in der Baustelle eingetragen wurden, so werden diese Werte benutzt, falls nicht, so werden die Einstellungen aus der Kundendatei vorbelegt. Die Transporteurnummer wird aus der Fahrzeugdatei übernommen. Diese Felder stehen Ihnen dann zum Ausdruck auf dem Lieferschein zur Verfügung.

Die folgenden Felder sind identisch mit den entsprechenden Feldern der Kundenstammdatei:

Gesamtmenge pro Tag:

Gesamtmenge pro Monat:

Gesamtmenge pro Jahr:

Informationen zum Korrigierren bzw. Editieren der eingegebenen Daten finden Sie im Kapitel 2 unter Das Editieren von Daten auf Seite 9.

Außer dem Feld Materialnummer lassen sich alle Felder korrigieren. Die Materialnummer kann nur über die Funktion Löschen eines Satzes gelöscht werden.

Bitmap:

Falls Sie zu dem Material ein LOGO (z. B. CE-Zeichen) drucken möchten, so müssen Sie wird hier der Name der Bilddatei hinterlegt. Der Name der Bilddatei wird Ihnen bei der Installation bzw. von Ihrem Systemadministrator mitgeteilt. Somit können für die Materialien unterschiedliche Logos gedruckt werden.

Kraftfahrzeugdatei

Felder der Fahrzeugdatei

Code für Kraftfahrzeug:

Ist ein 12-stelliges, alphanumerisches Feld, in welches jedes beliebige Zeichen geschrieben werden kann, und wird als eindeutiger Schlüssel zum schnellen Auffinden des Datensatzes verwendet. Bei der Eingabe von Daten in Schlüsselfelder werden Kleinbuchstaben automatisch in Großbuchstaben umgewandelt.

Zum leichteren Auffinden von Kraftfahrzeugen, ohne jedemal das vollständige KFZ-Kennzeichen eingeben zu müssen, kann für jedes KFZ ein Zeichen oder eine Zahl verwendet werden.

Achtung: Keine Blank, keine Bindestriche.

Kennung Fremd/Eigen:

Diese Kennung wird für die Fahrzeugstatistik benutzt.

KFZ-Kennzeichen:

Ist ein 12-stelliges, alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann, und wird als Mehrfachschlüssel zum schnellen Auffinden von Datensätzen verwendet. Bei der Suche über dieses Feld muß nicht das vollständige KFZ-Kennzeichen eingegeben werden, sondern es genügt der Eintrag des ersten oder der ersten 2 bzw. 3 Zeichen. Bei der Eingabe von Daten in Schlüsselfelder werden Kleinbuchstaben automatisch in Großbuchstaben umgewandelt.

Fuhrunternehmernummer:

Ist ein 6-stelliges, linksbündiges, numerisches Feld und kann für betriebsinterne Zwecke benutzt werden.

Fuhrunternehmername:

Ist ein 25-stelliges alphanumerisches Feld, in welches jedes Zeichen geschrieben werden kann.

Tara:

Ist ein 5-stelliges, numerisches Feld zur Speicherung des Taragewichts des Fahrzeugs. Nach jeder Taraverwiegung und anschließender Lieferscheinerstellung wird dieses Feld vom neu ermittelten Taragewicht überschrieben. Das Programm schreibt vor jede eingegebene Zahl führende Nullen (aus 3500 kg wird 03500 kg).

Kennung Tara:

Ist ein 1-stelliges Feld. >Hier wird vom Programm festgehalten, ob das Taragewicht von der Waage (S=Speicher) oder von Hand eingegeben worden ist. Der Bediener kann in diese Feld nichts schreiben.

Erstgew:

Zweitgew:

Sind vom Programm benutzte 5-stellige numerische Felder. Der Bediener hat keinen Zugriff auf diese Felder. Das Programm benützt diese Felder zur Zwischenspeicherung von Tara- oder Bruttogewicht.

Datum1:

Ist ein Datumsfeld, das dem Bediener nicht für Eingaben zur Verfügung steht. Das Programm protokolliert in diesem Feld das Erfassungsdatum bzw. das Datum der letzten Korrektur an diesem Datensatz.

Datum2:

Ist ein Datumsfeld, das dem Bediener nicht für Eingaben zur Verfügung steht. Das Programm protokolliert in diesem Feld das Ausstellungsdatum des letzten Lieferscheines, der für dieses Fahrzeug abgefertigt wurde.

Zeit1:

Ist ein 5-stelliges Feld, das dem Bediener für Eingaben nicht zur Verfügung steht. Das Programm speichert in diesem Feld die Uhrzeit der Erfassung bzw. der letzten Korrektur an diesem Datensatz.

Zeit2:

Ist ein 5-stelliges Feld, das dem Bediener für Eingaben nicht zur Verfügung steht. Das Programm speichert in diesem Feld die Uhrzeit der Erstellung des letzten Lieferscheins für dieses Fahrzeug.

Beförderernummer:

Hier tragen Sie die Beförderernummer ein. Dies ist normalerweise nicht Ihre Spediteuernummer. Für die Rechnungsschreibung, z. B. mit Wöhwa Faktura, haben Sie dem Spediteur eine eigene Nummer vergeben. Es ist aber möglich, daß der Spediteur eine eigenen Beförderernummer hat. Diese können Sie hier eintragen. Diese Nummer wird aber nur dann auf dem Lieferschein ausgedruckt, wenn ein Material mit einem Abfallschlüssel ausgewählt wurde. Diese Beförderernummer wird dann auch in der Statistik über „Abfallmaterial“ ausgedruckt.

Die folgenden Felder sind identisch mit den entsprechenden Feldern der Kundenstammdatei:

Gesamtmenge pro Tag:

+Gesamtmenge pro Monat:

Gesamtmenge pro Jahr:

Informationen zum Korrigieren bzw. Editieren der eingegebenen Daten finden Sie im Kapitel 2 unter Das Editieren von Daten.

Außer den Feldern Code für Kraftfahrzeug, Kennung Tara, Erstgew., Zweitgew., Datum1 und Datum2, Zeit1 und Zeit2, lassen sich alle Felder korrigieren.

Der Code für Kraftfahrzeug kann nur über die Funktion Löschen eines Satzes gelöscht werden.

Kartendatei:

Funktion und Aufbau.

Die Kartendatei ist die wichtigste Datei im täglichen Wiegebetrieb, wenn Fahrzeuge regelmäßig für eine Baustelle und/oder einen Fuhrunternehmer fahren. Der Bediener gibt die Kartennummer für das Fahrzeug ein und alle für die Erstellung des Lieferscheins benötigten Daten (KFZ-Kennzeichen, Fuhrunternehmer, Kundennummer, Kundenname, Baustelle, Material) werden sofort auf dem Bildschirm angezeigt. Mit Hilfe dieser Datei kann sehr viel Zeit bei der Erstellung von Lieferscheinen gewonnen werden.

Die Kartendatei ist zwar in die Kategorie Stammdaten eingeordnet, ist aber insofern ein Sonderfall, indem die Informationen sowohl im voraus (als Stammdaten), als auch während des ablaufenden Wiegebetriebs (bei der Lieferscheinerstellung) erfaßt werden können. Der Anwender muß selbst entscheiden, wie und wann er die Karten für die Kartendatei anlegen will. Es ist jedoch unbedingt erforderlich, daß vor dem Anlegen der Kartendatei die Stammdaten in die Kraftfahrzeug-, Kunden-, Baustellen und Materialdateien eingetragen worden sind. Um Ihnen die Entscheidung zu erleichtern, folgt eine Erläuterung der in der Kartendatei erfaßten Informationen sowie der Handhabung dieser Datei.

Unter dem Suchschlüssel Kartennummer wird je ein Satz mit Stammdaten aus den Kraftfahrzeug-, Kunden-, Baustellen- und Materialdateien gespeichert. Durch Eingabe einer Zahl oder einer beliebigen Buchstabenkombination im Feld Kartennummer ist es möglich, die gespeicherten Daten für ein Kraftfahrzeug aufzurufen, das für einen bestimmten Kunden und eine Baustelle mit einem bestimmten Material fährt.

Beispiel:

Unter der Kartennummer KJ363 könnte man die Sätze

- Kundennummer 2

- Baustellennummer 3

- Kraftfahrzeug KÜN-KJ 363

- Materialnummer 1

speichern. Die unter diesen Nummern gespeicherten Daten aus den 4 Stammdatendateien (Kraftfahrzeuge, Kunden, Baustellen, Materialien) können durch Eingabe der Kartennummer KJ363 auf dem Bildschirm angezeigt werden.

Der Nutzen dieser Datei liegt im Wiegebetrieb bei der Lieferscheinerstellung.

Kartennummer:

Ist ein 12-stelliges, alphanumerisches Eingabefeld und wird als eindeutiger Schlüssel verwendet.

Einige Kunden vergeben Kartennummern, die auf den Fahrzeugen gut sichtbar angebracht sind. Sobald ein derartig gekennzeichnetes Fahrzeug an der Waage erscheint, gibt der Bediener bei der Lieferscheinerstellung die entsprechende Kartennummer ein und die dazugehörigen Informationen werden automatisch in die Lieferscheinfelder übertragen.

Andere Kunden wiederum bevorzugen den Gebrauch des KFZ-Kennzeichens als Kartennummer. In vielen Fällen genügt es, nur die erste oder die zweite Hälfte des Kennzeichens zu verwenden:

Eingabe:

Kennzeichen: Eingabe:

KÜN –PX 59 KÜNPX59 oder PX59

Bei der Eingabe von Daten in Schlüsselfelder werden Kleinbuchstaben automatisch in Großbuchstaben umgewandelt.

Die nun folgenden Felder werden aus den 4 oben genannten Dateien übernommen und deshalb hier nicht mehr genauer beschrieben.

Aus der Kraftfahrzeugkartei

- Code für Kraftfahrzeug:

- KFZ-Kennzeichen:

- Fuhrunternehmernummer:

- Fuhrunternehmername:

Aus der Kundendatei

- Kundennummer:

- Matchcode:

- Name1:

- Name2:

Aus der Baustellendatei

Baustellennummer:

.......Matchcode

.......Baustellenbezeichnung1:

Baustellenbezeichnung2:

Aus der Materialdatei

.......Materialnummer:

.......Materialbezeichnung1:

.......Materialbezeichnung2:

Parameterdatei

In die Parameterdatei werden die Stammdaten für die Lieferscheinerstellung eingetragen, wie z.B. der Mehrwertsteuersatz, der Skontosatz, etc.

Felder der Parameterdatei:

Parametersatznummer:

Immer 1

Lieferscheinnummer:

Ist ein 6-stelliges numerisches Feld. In dieses Feld geben Sie bei der Inbetriebnahme des Programms die Zahl ein, bei der die Lieferscheinnummerierung beginnen soll. Der erste erfaßte bzw. gedruckte Lieferschein erhält dann diese Nummer. Bei allen nachfolgenden Lieferscheinen wird die Nummer in diesem Feld jeweils um den Wert 1 erhöht. Aus der Parameterdatei ist somit jederzeit die zuletzt erfaßte Lieferscheinnummer ersichtlich.

Mehrwertsteuer:

Ist ein 4-stelliges, numerisches Feld mit 2 Vor- und 1 Nachkommastelle. Der eingegebene Wert wird bei einem Barverkauf vom Programm für die Berechnung der Mehrwertsteuer verwendet.

Mit/ohne Uhrzeit:

Ist ein 1-stelliges Feld, in welches nur J oder N geschrieben wird. Das Feld wird in der aktuellen Version vom Programm noch nicht unterstützt, kann jedoch auf Kundenwunsch aktiviert werden.

Skonto:

Ist ein 3-stelliges, numerisches Feld mit 1 Vor- und 1 Nachkommastelle. In der aktuellen Version wird dieses Feld vom Programm noch nicht unterstützt, kann jedoch auf Kundenwunsch aktiviert werden.

Werksnummer:

Ist ein 2-stelliges, alphanumerisches Feld.

Wäger:

Ist ein 25-stelliges, alphanumerisches Feld zur Aufnahme des Namens des Wiegemeisters bzw. des Programmbedieners.

Summe Barverkauf:

Ist ein 8-stelliges, numerisches Eingabefeld. In diesem Feld werden vom Programm sämtliche Barverkäufe unabhängig von den verkauften Materialsorten aufaddiert.

Kundennummer für Handeingabe:

Diese Nummer wird für die Lieferscheinerstellung von Kleinkunden benötigt, wenn keine Rechnung erstellt und der Kunde nicht in der Kundendatei abgespeichert werden soll.

Bei Eingabe der hier abgespeicherten Nummer im Wiegebetrieb bei der Lieferscheinerstellung, werden die Felder mit den Kundendaten für manuelle Eingaben freigegeben. Die gegen diese Kundennummer gemachten Eingaben in der Lieferscheinmaske erscheinen jedoch nur auf dem Lieferscheinausdruck und werden nicht in der Kundendatei abgespeichert. Viele Programmanwender lassen die Felder mit den Kundendaten in so einem Fall frei (=die Felder werden mit Enter übersprungen), da es sich meist um belanglose Barverkäufe handelt.

In diesem 5-stelligen, numerischen Feld sollte eine Nummer eingegeben werden, die mit einer regulären Kundennummer nicht verwechselt werden kann. Wir empfehlen den Gebrauch von Sonderzahlen wie z. B. 999999 für dieses Feld. Das Programm schreibt vor jede eingegebene Zahl führende Nullen, z. B. wird die Zahl 999 als 000999 dargestellt.

Kundennummer für Barverkauf:

Dieses Feld wird benötigt für die Lieferscheinerstellung, wenn eine Rechnung erstellt und der Kunde nicht in der Kundendatei abgespeichert werden soll.

Bei Eingabe der hier abgespeicherten Nummer bei der Lieferscheinersellung im Wiegebetrieb wird in der Lieferscheindatei vermerkt, daß es sich um einen Barverkauf handelt und die Daten werden nicht in die Kundendatei übernommen. Nach Eingabe dieser Nummer werden die Felder mit den Kundendaten für manuelle Eingaben freigegeben. Die gegen diese Kundennummer gemachten Eingaben in der Lieferscheinmaske erscheinen jedoch nur auf dem Lieferscheinausdruck und werden nicht in der Kundendatei abgespeichert. Viele Programmanwender lassen die Felder mit den Kundendaten in so einem Fall frei (=die Felder werden mit Enter übersprungen), da es sich um belanglose Barverkäufe handelt.

In diesem 6-stelligen, numerischen Feld sollte eine Nummer eingegeben werden, die mit einer regulären Kundenummer nicht verwechselt werden kann. Wir empfehlen den Gebrauch von Sonderzahlen wie z. B. 888888 für dieses Feld. Das Programm schreibt vor jede eingegebene Zahl führende Nullen, z. B wird die Zahl 888 als 000888 dargestellt.

Baustellennummer für Handeingabe:

Dieses Feld wird benötigt für die Lieferscheinerstellung von Kleinkunden, wenn die Baustellendaten nicht in der Baustellendatei abgespeichert werden sollen.

Bei Eingabe der hier abgespeicherten Nummer bei der Lieferscheinerstellung im Wiegebetrieb werden die Felder mit den Baustellendaten für manuelle Eingaben freigegeben.Die gegen diese Baustellennummer gemachten Eingaben in der Lieferscheinmaske erscheinen jedoch nur auf dem Lieferscheinausdruck und werden nicht in der Baustellendatei abgespeichert. Viele Progammanwender lassen die Felder mit den Baustellendaten in so einem Fall frei(=die Felder werden mit Enter übersprungen), da es sich um belanglose Barverkäufe handelt.

In diesem 8-stelligen, numerischen Feld sollte eine Nummer eingegeben werden, die mit einer regulären Kundennummer nicht verwechselt werden kann. Wir empfehlen den Gebrauch von Sonderzahlen wie z. B. 99999999 oder 88888888 für dieses Feld. Das Programm schreibt vor jede eingegebene Zahl führende Nullen, z. B. die Zahl 999 als 00000999 dargestellt.

Papiereinzug und Papierabzug:

Diese Steuerwert sind für besondere Anwendungen reserviert, und sollten mit 0 und 48 vorbelegt bleiben.

Einmalkarte: Mit dieser Kartennummer kann im Wiegebetrieb das Feld Kartennummer verlassen werden. Die Lieferscheindaten werden dann nicht unter einer Karte gespeichert. (Div. Karte)

Neue Seite je Kunde und neue Seite je Baustelle sind ebenfalls für spätere Erweiterungen vorgesehen.

Als Bildschirmschohner sollte derjenige von Windows benutzt werden. Geben Sie hier 999 ein.

Mat-LS-Kreis (Unterpunkt Parameterdatei)

Felder der Mat-LS-Kreis

In diesen Feldern geben Sie die Lieferscheinkreise für 2. Und 3. Lieferscheinkreis ein. Bitte beachten Sie, daß sich die Lieferscheinnummern nicht überschneiden dürfen.

Im Wiegebetrieb erfolgt die Abfrage des Druckerkreises, bzw. Lieferscheinkreises. Wenn Sie eine 1 eingeben, so wird der Lieferschein für das Werk gedruckt, welches in der Parameterdatei am Anfang eingestellt ist.

Geben Sie im Wiegebetrieb eine 2 ein, so wird der Lieferschein für den 1. zusätzlichen Kreis erstellt. Der Lieferschein wird unter Werk in diesem Beispiel Werk 2 erstell, und auf dem eingestellten Drucker (hier im Beispiel LPT1). gedruckt.

Geben Sie im Wiegebetrieb eine 3 ein, so wird der Lieferschein für den 2. zusätzlichen Lieferscheinkreis gedruck.t. In diesem Beispiel würde der Lieferschein auf LPT2 gedruckt werden.

Parameterdatei Menue Zufuhrarten:

Nach der Auswahl der Parameterdatei haben Sie die Möglichkeit die Zufuhrarten einzutragen. Geben Sie in der Tabelle Ihre Zufuhrarten ein. Z. B. 0 Frei Bau

1 Ab Werk.

Bitte beachten Sie, daß keine Felder leer sein dürfen. Haben Sie nur 2 Zufuhrarten, so füllen Sie die restlichen Felder mit den selben Werten aus, z. B. alle restlichen Felder mit 1 und Text Ab Werk..

Einst. Ton.

Bei Ausführung in der Schweiz, und bei einigen Deponien wird der Ausdruck in cbm und Tonnen, oder nur in cbm gewünscht. Hierzu kann das Programm so eingestellt werden, daß es entweder

Nur in Tonnen

In Tonnen und cbm (Kubikmeter)

Nur in Kubikmeter

arbeitet. Standardmäßig ist das Programm auf nur in Tonnen eingestellt.

System:

Dieses Menu ist nur über ein Paßwort möglich. Hier wird die Einstellung der Waagen verwaltet. Ein Eingriff sollte nur nach Rücksprache mit Wöhwa erfolgen.

Wiegebetrieb

Ablauf Wiegebetrieb

Standardmodus:

F5===> L I E F E R S C H E I N

1 x F5 drücken:

F5===> T A R A W Ä G U N G

2 x F5 drücken:

F5===> B R U T T O W Ä G U N G

Aus dem Modus BRUTTOWÄGUNG gelangt man durch nochmaliges Drücken der Funktionstaste F5 wieder in den Lieferscheinmodus zurück.

Taraverwiegung

Nach Anwahl des Programmmodus „TARAWÄGUNG“ mit der Funktionstaste F5, geht man wie folgt vor:

Zunächst ruft man eine Kartennummer auf. Wenn Sie noch nicht mit der Kartendatei vertraut sind, schlagen Sie bitte erst in Kapitel 9 die Handhabung der Kartendatei nach. Manche Anwender von GYRO-DATA haben für ihren Betrieb ein Nummernsystem eingeführt und geben jedem Fahrzeug eine Nummer, die daran gut sichtbar angebracht wird. Die Fahrzeugnummern werden gleichzeitig als Kartennummern verwendet. Sobald ein gekennzeichnetes Fahrzeug an die Waage fährt, gibt der Bediener die entsprechende Kartennummer ein und die dazugehörigen Informationen werden automatisch in die Lieferscheinfelder eingelesen.

Für alle nicht gekennzeichneten Fahrzeuge hat es sich bewährt, die KFZ-Kennzeichen der Fahrzeuge für die Kartennummer zu verwenden. Meist genügt es, nur die erste oder die zweite Hälfte des Kennzeichens zu verwenden:

Beispiel:

Kennzeichen: Eingabe:

KÜN-NM 45 NM45 oder KÜNNM45

Bei der Eingabe von Daten in Schlüsselfelder werden Kleinbuchstaben automatisch in Großbuchstaben umgewandelt. Existiert noch keine Kartennummer für das Fahrzeug und es soll nur das Taragewicht eines Fahrzeuges abgespeichert werden, so brauchen keine Angaben in den Feldern Kundennummer, Baustellennummer, Materialnummer gemacht zu werden. Man braucht dann nur das Kraftfahrzeugkennzeichen einzugeben. Das Taragewicht wird unter diesem Fahrzeug abgespeichert. Wird später ein Lieferschein für dieses Fahrzeug ausgestellt, so liegt das Taragewicht in der Kraftfahrzeugdatei bereit.

Bruttoverwiegung

Die Bruttoverwiegung funktioniert im Prinzip wie die oben beschriebene Taraverwiegung.

Lieferscheinerstellung

Nach Anwahl der Funktion „Wiegebetrieb“ im Hauptmenü erscheint folgende Maske auf dem Bildschirm:

Auch im Lieferscheinmodus verlangt das Programm zunächst die Eingabe einer Kartennummer wie vorstehend unter der Beschreibung für die Taraverwiegung bereits beschrieben.

Bei der Eingabe von Daten in Schlüsselfelder werden Kleinbuchstaben automatisch in Großbuchstaben umgewandelt. Existiert noch keine Kartennummer für das Fahrzeug, so kann sie jetzt im Wiegebetrieb angelegt werden. Das Programm meldet bei einer unbekannten Kartennnummer in der Fußzeile

Kein Datensatz mit der Nr. ... vorhanden

Die Meldung bleibt nur für wenige Momente am Bildschirm und wird dann ersetzt durch die Meldung

Neuen Satz erfassen X = Neueingabe

Die Meldung „Neuen Satz erfassen“ ist rot unterlegt und kann mit Enter bestätigt werden. Der CURSOR springt dann in das Feld „Kundennummer“. Ist die Kundennummer nicht bekannt, so können Sie durch Betätigung der Funktionstaste F9 die Kundenliste am Bildschirm anzeigen lassen. Zum schnelleren Auffinden der Daten kann man auch den Matchcode eingeben oder die ersten Buchstabenkombinationen und anschließend sofort die Funktionstaste F9 betätigen. Der Einstieg in die Listenanzeige wird hierdurch gezielter.

Beispiel:

Gesucht wird der Kunde mit dem Namen Hintereder. Wenn Sie im Matchcode Hint eintippen, beginnt die Listenanzeige bei dem Namen, der mit Hint beginnt.

In der Liste kann mit den Bild-Auf und Bild-Ab-Tasten geblättert und der gesuchte Datensatz mit den Pfeiltasten angewählt werden. Duch Betätigung der Enter-Taste wird der ausgewählte Datensatz auf den Bildschirm geholt und die benötigten Informationen werden in die entsprechenden Lieferscheinfelder geschrieben. Voraussetzung hierfür ist natürlich, daß die Kundenstammdaten bereits eingegeben worden sind. Sind noch keine Stammdaten eingegeben, so können diese jetzt während des Lieferscheinbetriebs in dieser Maske erfaßt werden. Das Programm legt sie automatisch in den entsprechenden Stammdatendateien ab.

Alternativ zu der Suchmethode am Bildschirm kann man auch Listenausdrucke der Stammdaten Kunden, Baustellen, Materialien und Kraftfahrzeuge bereit halten, um die entsprechenden Informationen schnell aufzufinden.

Wird eine Kartennummer verwendet, die bereits in den Stammdaten existiert, so werden die Daten auf dem Bildschirm in den entsprechenden Feldern angezeigt. Der CURSOR bleibt auf dem Feld „Zufuhrart“ stehen.

Mit den Tasten Pfeil hoch und Pfeil unten können den CURSOR in die Schlüsselfelder (Code KFZ, Materialnummer, Baustellennummer und Kundennummer) setzen, um eventuelle Änderungen vorzunehmen.

Beispiel:

Steuern Sie das Feld „Baustellennr.“ an. Wenn Sie jetzt eine andere Baustelle eingeben wollen, tippen Sie die entsprechende Nummer und betätigen Sie diese mit Enter. Das Programm sucht diese Baustelle in den Stammdaten und zeigt sie in der Maske an. Der CURSOR springt anschließend in das Feld Materialnummer.

Wenn Sie im Feld Baustellennummer statt der Enter-Taste die Pfeil-unten-Taste betätigen, bleibt der Cursor im Feld Matchcode stehen. Sie können jetzt einen Baustellensatz mit dem Matchcode suchen.

Beispiel:

Will man z. B. die Baustelle „Hungerfeldweg 15“ suchen, schreibt man in das Feld Matchcode „Hu“ und drückt die Funktionstaste F9. Auf dem Bildschirm erscheint eine Liste der Baustellen, die mit „Hu“ beginnen. Gibt es keine Baustelle mit „Hu“ bleibt der CURSOR in der Listenanzeige auf der nächstmöglichen Buchstabenkombination stehen. Jetzt können Sie den gesuchten Satz mit den Pfeiltasten anwählen und mit Enter auf den Bildschirm holen.

Das Programm funktioniert ähnlich bei den anderen Schlüsselfeldern. Wenn alle Daten im Lieferschein stimmen, wird vom Feld „Zufuhrart“ mit der Enter-Taste des Einlesen des Gewichtes von der Waage ausgelöst. Kommt von der Waage kein Gewicht, z. B. bei einer Störung, erscheint am Bildschirm die Meldung

Waage sendet kein Gewicht!!! F3 drücken für Handeingabe

Die Gewichtsdaten könnten jetzt auch von Hand eingegeben werden. Anschließend erscheint die Anzeige:

Fertig/Korrigieren/X = Neueingabe

Sind alle Daten richtig und werden diese bestätigt, so wird der Lieferscheindruck ausgeführt. Wird „Korrigieren“ gewählt, kann jedes Schlüsselfeld wieder erreicht und andere Datensätze ausgesucht werden. „X = Neueingabe“ löscht den Bildschirminhalt und erwartet die Eingabe einer anderen Kartennummer.

Vorgehensweise bei noch nicht erfaßten Stammdaten:

Wird im Lieferscheinmodus eine neue Kartennummer mit neuen Stammdaten erfaßt, also ein neuer Kunde, eine neue Baustelle, etc. so ist wie folgt vorzugehen;

Bei Eingabe einer Kundennummer, die noch nicht in den Stammdaten abgelegt wurde, erscheint die Meldung:

Kein Datensatz mit der Nr. ... vorhanden

Die Meldung bleibt nur für wenige Momente am Bildschirm und wird dann ersetzt durch die Meldung:

Einfügen/M=Einfügen mit Maske/X=Neueingabe

Mit „E=Einfügen“ können die Daten in der Lieferscheinmaske erfaßt werden. Wird jedoch „M=Einfügen mit Maske“ angewählt, verzweigt das Programm in die Kundendatei und bringt folgende Eingabemaske:

Maske mit Kundennummer 1 als Beispiel

Die Daten können eingegeben werden wie in Kapitel 5 auf Seite 16 beschrieben.

Nach Betätigung der eingegebenen Daten mit Enter springt das Programm in die Lieferscheinmaske zurück und bleibt im Feld Baustellennr. stehen.

Mit neuen Baustellennummern und KFZ-Codes wird ebenso verfahren wie oben bei neuen Kundennummer beschrieben.

Nach Eingabe der Zufuhrart werden die Gewichtsdaten von der Waage eingelesen und folgende Meldung erscheint in der Fußzeile des Bildschirms:

Fertig/Korrigieren/X=Neueingabe

Wenn alle Eingaben korrekt sind und der Drucker bereit ist, kann man Fertig mit Enter bestätigen und der Lieferschein wird ausgedruckt.

Regeln für die Eingabe der Kartennummer

Für bekannte Fahrzeuge geben Sie das Kennzeichen ein z. B. KÜNPX59.

Für Barverkauf legen Sie sich Karten an z. B. BAR1.

Für Einmalkunden können Sie die 0 als div. Karte verwenden.

Für div. Kunden die mehrmals kommen legen Sie Karten an z. B. DIV1, DIV2

Hofliste

Funktion:

Nach einer Eingangswiegung (Brutto- oder Tarawiegung) wird das Fahrzeug in der Hofliste gespeichert. Über die Funktionstaste F7 kann im Wiegebetrieb die Hofliste aufgerufen werden. Damit ist eine schnelle Auswahl möglich. In dieser Liste sind nur die Fahrzeuge enthalten, welche eine Eingangs- und noch keine Ausgangswägung gemacht haben. Nach einer Lieferscheinerstellung wird das Fahrzeug aus der Hofliste gelöscht.

Hofliste löschen

Die Hofliste kann (falls notwendig) komplett über den Menüpunkt Zusätze, Hofliste löschen gesamt gelöscht werden.

Lieferscheindatei

Korrektur der Lieferscheine

Rufen Sie den Lieferschein anhand der Nummer auf. Zum Korrigieren drücken Sie die Schaltfläche. Im Feld gültig geben Sie eine 0 ein. Der Liefeschein ist nun ungültig, der Nettowert wird wieder von der Statistik subtrahiert.

Geben Sie eine 1 ein, so können Sie den Lieferschein korrigieren. Die Statistik wird entsprechend der Eingaben mitgeführt.

Drucken:

Lieferscheindruck

Der Lieferschein wird direkt auf den Drucker ausgegeben. Hierzu muß ein Drucker mit DOS-Zeichensatz zur Verfügung stehen. Dies ist bei einem Nadeldrucker in aller Regel der Fall. Der Zeichensatz muß auf 10CPI und Deutsch eingestellt werden. Weitere Informationen siehe Parametrierung der Schnittstellen.

Statistikdruck

Statistiken und Lieferscheinprotokoll werden über Windows-Druckertreiber gedruckt. Hierzu muß der

entsprechennde Windowstreiber installiert sein.

Aus der Liste der Drucker können Sie auch Bildschirm auswählen. Sie erhalten dann die Liste auf dem Monitor.

Anbei ein Auszug aus einer Statistik. In diesem Fall über Abfallmaterial, d. h. in dieser Liste sind nur solche Materialien enthalten, die im Feld Abfallschlüssel einen Eintrag haben. Jeder Lieferschein für den vorgewählten Zeitraum wird aufgelistet, und mit Lieferscheinnummer, Datum, KFZ, Transporteur, Menge, Entsorgernummer und Entsorgernachweissnummer aufgelistet.

In ähnlicher Form kann auch eine Liste für alle Lieferscheine nach Kunden-Baustellen-Materialsortierung aufgelistet werden.

Auswahl Statistikdruck

Hier können Sie den Datenbereich und die Sortierung der Statistiken auswählen. Diese Statistik steht Ihnen dann in gleicher Weise für Abfallmaterial zur Verfügung.

Materialstatistik

Stammdatensicherung.

Eine Stammdatensicherung sollte in regelmäßigen Abständen erfolgen. Die Sicherung kann auf einen anderen Rechner im Netzwerk, über DFÜ auf andere PC’s oder auf Diskette erfolgen. Sensible Stammdaten müssen vor Umwelteinflüssen geschützt aufbewahrt werden.

Lieferscheine

Allgemeines.

Das Programm kann standardmäßig 3 unterschiedliche LS-Kreise verarbeiten, die jeweils auch unterschiedliche Lieferscheinformulare haben können. Und auch auf unterschiedlichen Drucker ausgedruckt werden können. Die Lieferscheinkreise sind an die Werknummern gebunden, d. h. jedem Lieferscheinkreis muß ein Werk zugeordnet werden. Selbstverständlich kann auch nur mit einem Lieferscheinkreis gearbeitet werden.

Notwendige Einstellungen.

Lieferscheinformulare

Die einzelnen LS-Formulare werden über das Menü Zusätze -> Lieferscheinformular -> für Kreis1, 1. zusätzlicher Lieferscheinkreis und 2. zusätzlicher Lieferscheinkreis eingestellt.

Im Parametersatz wird die Werknummer und die Lieferscheinnummer für LPT1 eingetragen. Im Material-LS-Kreis wird die Lieferscheinnummer für Kreis2 und Kreis 3 eingetragen. Die zugehörige Werknummer und der Druckerport muß ebenfalls eingetragen werden.

Bei der Lieferscheinerstellung wird der Druckerkreis abgefragt. Bei 1 werden die Lieferscheine auf LPT1 gedruckt. Bei 2 und 3 je nach Einstellung in der Parameterdatei. Die Auswahl, für welches Werk der Lieferschein gedruckt wird, erfolgt somit im Wiegebetrieb.

Lieferscheine an Faktura.

Die Lieferscheine werden entsprechend der Einstellung in der Parameterdatei in verschiedene Dateien übertragen. Für jedes unterschiedliche Werk wird eine Datei erstellt. Die Dateien sind: lsttmmww.dbf für alle Lieferscheine die die selbe Werknummer haben wie in der Parameterdatei eingestellt. tt== Tagesdatum, mm== Monatsnummer und ww== Werknummer. Diese Dateien werden in das entsprechende Unterverzeichnis kopiert. Der Name des Unterverzeichnisses wird vor der Übertragung abgefragt. Unter diesem Unterverzeichnis werden zusätzliche Verzeichnisse 1; 2 und 3 angelegt. LS-Kreis 1 wird in das Unterverzeichnis 1, LS-Kreis 2 in 2 und LS-Kreis3 in 3 kopiert. Die Datei liegt dann im dBASE IV – Format und im ASCII-Format vor. Falls die Lieferscheine per DFÜ übertragen werden sollen, so müssen Sie in der DFÜ-Software unterschiedliche Rechte vergeben, so daß nur der zugelassenen Lieferscheinkreis übertragen werden kann. Die Übertragung der Lieferscheine an die Faktura kann nur einmal am Tag erfolgen, damit die Sicherungsdatei nicht überschrieben wird. Die DBASE-IV Dateien haben die Endung .dbf, die ASCII-Dateien haben die Endung .txt.

Übertragung auf Diskette.

Sollen die Lieferscheindaten auf Diskette kopiert werden, so geben Sie bei der Abfrage a:\ ein. Damit kopiert das Programm die Lieferscheindaten auf die Diskette.

Übertragung per DFÜ

Die Lieferscheindaten werden (wie oben beschrieben) aufbereitet. Die Dateien stehen dann in dem angegebenden Verzeichniss zur Übertragung bereit. Eine DFÜ-Software kann dann diese Dateie(n) übertragen. Hierzu sind viele unterschiedliche Programme im Einsatz. Nach erfolgter Übertragung sollte das DFÜ-Programm die Dateien löschen. Falls Sie z. B. bei Lieferscheine an Faktura c:\dfue angegeben haben, so finden Sie die Lieferscheine von Werk1 in c:\dfue\1, für das 2. Werk in c:\dfue\2 und für das dritte Werk in c:\dfue\3.

Datensicherheit für die Übertragung.

Die Lieferscheindatei wird nach der Aufbereitung der Daten gelöscht, d. h. für den Wiegemeister sind die Daten nun nicht mehr sichtbar. Die Lieferscheine werden aber noch mind. für 1 Jahr gespeichert. Falls Sie eine Diskette verloren haben, bzw. die Datei bei der Übertragung nicht richtig kopiert wurde, so können Sie die Übertragung noch einmal durchführen. Hierzu gehen Sie folgendermaßen vor. Wählen Sie den Menüpunkt Lieferscheine an Faktura, und dort die gesicherten Lieferscheine aus. Geben Sie das Tagesdatum der Übertragung ein, die Sie noch mal erstellen wollen. ACHTUNG: Es wird nur das Tagesdatum berücksichtigt. Die Lieferscheindatei wird nun erneut aufbereitet, und steht nun zur Übertragung (bzw. auf Diskette) zur Verfügung.

Lieferscheinformular einstellen

Sie können das Lieferscheinformular selbst gestalten. Hierzu sind im Menue Zusätze 3 Unterpunkte. Für jeden der 3 unterschiedlichen Lieferschienkreise kann das Formular gestaltet werden. Sie können jeder Druckfeld beliebig oft auf dem Drucker ausgeben. Z. B. kann die Kundennummer bei der Adresse, bei der Baustelle und noch am Schluß des Lieferscheines ausgedruckt werden. Für jedes druckbare Feld geben Sie die Zeile, Spalte und die Länge der Daten an.

Wir unterscheiden 2 Feldtypen.

1) Felder die variable Lieferscheindaten ausdrucken. Dies sind z. B. die Lieferscheinnummer, Kundennummer; d. h. alle Felder die bei der Lieferscheinerstellung ausgewählt werden.

2) Textfelder. Bei diesen Feldern wird der zu druckende Text direkt bei dem Feld hinterlegt. Z. B. für Barverkaufstext kann dann lauten: „Betrag dankend erhalten.“ Dieser Text würde nun immer bei einem Barverkauf gedruckt werden.

3)

Maske für die Einstellung des Lieferscheinformulares

Beispiel 1: Neuanlage eines freien Textes.

Sie wollen am Ende des Lieferscheines einen Text ausgeben: „Wir haben bis 07.01.2001 geschlossen“. Wählen –Sie im Menü Zusätze den entsprechenden Lieferscheinkreis aus. Drücken Sie nun F9 für die Liste der zu druckenden Felder. Gehen Sie mit Pfeil (Cursor) ab ans Ende der Liste. Nehmen wir an, daß das letzte Feld in Zeile 24 Spalte 10 gedruckt wird. Wir wollen den neuen Text 2 Zeilen unterhalb drucken, also in Zeile 26. Drücken Sie nun ESC, und wählen Sie aus dem Auswahlfenster das Feld „Freier Text“ aus. Bestätigen Sie die Auswahl. Es erscheint nun die Abfrage: Feld hat noch keine Druckeingaben. Neues Druckfeld anlegen?“ oder (falls schon vorhanden) „Feld hat schon Druckangaben: Neues Feld anlegen. Unabhängig welche Meldung erscheint, legen Sie ein neues Druckfeld an. Geben Sie in Zeile „26“, bei Spalte „10“ von Zeichen „1“ bis Zeichen „50“ an. Der maximal mögliche Wert für bis Zeichen wird beim Druckfeld mit angezeigt. Im Feld Text geben Sie nun Ihren Text ein. Nach erfolgter Eingabe erstellen Sie einen Lieferschein. Der neu angelegte Text wird nun gedruckt.

Beispiel 2: Verschieben der Kundennummer .

Wir wollen den Ausdruck der Kundennummer um 2 Zeilen nach unten, und 3 Zeichen nach rechts verschieben. Wählen Sie auch hier wieder im Menue Zusätze das entsprechende Formular aus. Suchen Sie in der Auswahlliste das Feld „Kundennr“. Bestätigen Sie das Feld. Es erscheint nun die Abfrage:

„Feld hat schon Druckeingaben. Neues Feld anlegen“. Bestätigen Sie hier nein, da wir kein neues (zusätzliches) Druckfeld anlegen möchten. Die Druckangaben der Kundennummer werden nun angezeigt. Zählen Sie für Zeile zum angezeigten Wert 2 hinzu, und zum Werk Spalte 3. Die Werte von Zeichen und bis Zeichen lassen Sie unverändert. Einen Text können Sie hier nicht eingeben, da für dieses Feld die im Lieferschein ausgewählte Kundennummer gedruckt wird.

Protokolle des eichfähigen Speichers ansehen (Option)

Über Zusätze – Speicher ansehen erscheint eine Auswahlmaske für den Datumsbereich. Geben Sie hier das Datum ein, für das Sie die Protokollnummer suchen. Anschließend erscheint die Liste der Protokollnummern mit dem Gewicht. Diese Daten können Sie auch auf einem Drucker auseben. Wenn die Nummer auf Anfangswert gesetzt wird, so wird ein Eintrag mit der Kennung BE für Beginn erzeugt.

Über den Menüpunkt Zusätze – Daten auslagern können Protokolldaten die älter als 3 Monate sind, ausgelagert werden. Sie sollten alle 6 Monate die älteren Daten auslagern, damit die Protokolldatei nicht zu groß wird. Die Berechnung der notwendigen Festplattengröße entnehmen Sie bitte der Zulassung für den eichf. Speicher.

DFÜ (Datenfernübertragung)

Anbei einige Bemerkungen zu Datenübertragung:

Hardware:

Analoge Modems

Jeder Windowsrechner kann prinzipiell über das Telefonnetz mit anderen Rechnern verbindung aufnehmen. Hierzu sind 2 unterschiedliche Geräte im Einsatz.

Analoge Modems für „ältere“ Telefone. Dies war früher Standard, wird heute aber oft durch ISDN ersetzt. Bitte beachten Sie, daß analoge Modems nicht mit ISDN in Verbindung treten können. Heute sind externe Modems mit 56KBd üblich. Diese Modems werden über serielle Schnittstelle mit dem Rechner verbunden, und über entsprechendes Kabel mit dem Telefonnetz.

ISDN

Im Bereich der ISDN-Anlagen wird die Fritzcard sehr häufig eingesetzt. Dies ist eine Steckkarte, die direkt in den PC eingebaut wird. Es sind jedoch auch externe ISDN-Modem möglich.

Software

Sobald mit der Hardware (siehe oben) die Voraussetzung geschaffen ist, kann über entsprechende Software eine Verbindung hergestellt werden. Dies setzt natürlich voraus, daß die Hardware richtig installiert wurde. Bei der Software sind sehr viele unterschiedliche Programme verfügbar. Das Programm GyroData bereitet die Daten entsprechend auf, die Übertragung der Daten kann dann mit einer DFÜ-Software erfolgen, so daß jeder Kunde die für Ihn passende Software einsetzten kann.

Dateien übertragen.

Meist ist bei der Hardware ein einfaches Programm für die Datenübertragung vorhanden. Bei der Fritzcard ist dies Fritzdata. Mit diesem Programm können Dateien übertragen werden. Hierzu muß auf einem Rechner die Software mit HOST-Modus (warte auf Anruf) laufen.Man kann sich in den Rechner einwählen, und Dateien in beide Richtungen übertragen. Der Dateitransfer wird vom Bediener gesteuert.

Es sind diverse andere Programme verfügbar mit denen auch ein automatischer Datentransfer gesteuert werden kann. Es muß jedoch immer auf beiden Rechnern eine DFÜ-Software aktiv sein.

Fernsteuerung (Fernwartung)

Falls eine Fernwartung des Programmes gewünscht wird, so empfehlen wir den Einsatz von PC-Anywhere. Wir können dann mit anlogem Modem oder ISDN-Karte auf den Rechner zugreifen. Für das Programm GyroData ist dies nicht unbedingt erforderlich, bei der Fakturierung dagegen dringend zu empfehlen.

Die Installation und Wartung des DFÜ-Software sollte vom PC-Lieferanten durchgeführt werden.

Sicherheit

Bei Verwendung von DFÜ-Software besteht die Möglichkeit, daß auf den PC in unerwünschter Weise zugegriffen werden kann. Entsprechende Schutzmaßnahmen müssen bereits vor der Installation abgesprochen werden.

Aufbau der Lieferscheindatei

Field Field Name Type Width Dec

1 DL_LIENR Character 10 Lieferscheinnummer *1

2 DL_POS Character 2 Position

3 DL_NAME1 Character 30 Kundenname 1

4 DL_BAUBEZ1 Character 30 Baustellenbezeichnung 1

5 DL_KNDNR Character 15 Kundennummer *1

6 DL_NAME2 Character 30 Kundenbezeichnung

7 DL_PLZ Character 5 PLZ

8 DL_ORT Character 30 Ort

9 DL_STR Character 30 Kundenstrasse

10 DL_LAND Character 3 Kunde Länderkennzeichnung

11 DL_BAUNR Character 15 Baustellennummer *2

12 DL_BAUBEZ2 Character 30 Baustellenbezeichnung 2

13 DL_MATNR Character 15 Materialnummer *1

14 DL_MATBEZ1 Character 30 Materialbezeichnung1

15 DL_MATBEZ2 Character 30 Materialbezeichnung2

16 DL_KFZCODE Character 12 KFZ-Code z. B. „PX59 „

17 DL_KENNZ Character 12 Kennz. z. B. „KÜN – PX 59 „

18 DL_FUHRNAM Character 25 Spediteurname

19 DL_FUHRNR Character 15 Spediteurnummer *1

20 DL_ZEIT1 Character 5 Zeit Eingangsverwiedung „ss:mm“

21 DL_ZEIT2 Character 5 Zeit Lieferscheinerstellung

22 DL_DATUM1 Date 8 Datum Eingangsverwiegung

23 DL_DATUM2 Date 8 Datum Lieferscheinerstellung

24 DL_ZUFART Character 1 Zufuhrart

25 DL_BARVER Character 1 Kennung Barverkauf 1=BV 0=kein BV

26 DL_GUELT Character 1 Kennung „1“=Gültig „0“=storniert

27 DL_BRUTTO Character 5 Bruttogewicht in kg

28 DL_TARA Character 5 Leergewicht in kg

29 DL_NETTO Character 7 Nettogewicht in kg „0012345“

30 DL_PREIS Numeric 7 2 Preis Barverkauf

31 DL_KM Numeric 6 2 Entfernung Baustelle in km

32 DL_KENNUNG Logical 1 für internen gebrauch

33 DL_WERKNR Character 2 Werknummer aus Parameterdatei

34 DL_BARNETT Numeric 7 2 Nettopreis Barverkauf

35 DL_BARMWST Numeric 7 2 MWst Barverkauf

36 DL_BARBRUT Numeric 7 2 Bruttopreis Barverkauf

37 DL_FRANETT Numeric 7 2 noch nicht benutzt

38 DL_FRAMWST Numeric 7 2 dito

39 DL_FRABRUT Numeric 7 2 Noch keine Fracht bei BV

40 DL_SKONPRO Numeric 7 2 % Skonto

41 DL_SKONBET Numeric 7 2 Skontobetrag bei Barverkauf

42 DL_WAEHRU Character 1 Währungszeichen E oder D

43 DL_ORTNR Character 4 Reserve

44 DL_NAME Character 25 Reserve

45 DL_DEBITKE Character 1 Reserve

46 DL_DEBITNR Character 15 Reserve

47 DL_EINHEIT Character 4 Mengeneinheit wenn nicht Tonnen

** 48 Satzende CR LF nur bei ASCII-Datei nach jedem Satz

Legende:

*1 Am Beispiel der Kundennummer: Die Länge der Kundennummer ist parametrierbar, und max. 15 Zeichen. Soll z. B. mit einer 6stelligen Kundennummer gearbeitet werden so werden die Felder folgendermaßen formatiert. Die 6stellige Kundennummer wird automatisch mit führenden Nullen gefüllt. Die Kundennummer 345 wird in der Datei gespeichert: „000345 + 9 Leerzeichen, also „000345 “ .

*2 Die Baustellennummer ist noch mit der Kundennummer versehen. Somit hat jeder Kunde seine eigenen Baustellen. Für Kunde 345 und Baustelle 1 ergibt sich: „000345001 + 6 Leerzeichen,

also „000345001 “

** Bei ASCII-Datei CRLF am Satzende. Bei dBase-Datei nur 47 Felder.

ACHTUNG: Bei der jeweiligen Installation kann der Aufbau der Lieferscheindatei in Teilen von dieser Beschreibung abweichen.

Ergänzende Beschreibung für GyroData.

Neuinstallation

Benötigt werden waage.exe und logo.bmp, und die dll-Dateien. Wenn keine weiteren Dateien vorhanden sind, so können die Stammdateien beim Programmstart angelegt werden. ACHTUNG: Es werden leere Stammdateien erzeugt. Bitte kopieren Sie keine dll-Dateien ins Unterverzeichniss von Windows.

Mehrfachinstallation:

Waagenprogramm (Datenserver)

In einem Unterverzeichniss (möglichst an der Waage) müssen die Stammdaten und die Programmdateien vorhanden sein. Diese Installation muß alleine lauffähig sein. Die Waage sollte einen Netzwerkanschluß nicht zwingend benötigen.

Arbeitsplatz zur Stammdatenpflege (Büro)

Weitere Programme können nun (z. B. über Netzwerk, RAS-Dienst) auf diese Stammdaten zugreifen.

Hierzu ist ein extra Unterverzeichniss (auf dem BüroPC) anzulegen. In dieses Verzeichniss müssen folgende Dateien kopiert werden.

waage.exe, logo.bmp, comdat.dbf, comdat1.ntx, locpara.dbf, system.dbf., und sämtliche dll-Dateien aus dem Unterverzeichniss der Waage.

Waage.exe und logo.bmp sind das Programm.. Die dll-Dateien sind Funktionsbibliotheken.

In der Datei locpara.dbf muß in dem 1.Satz im Datenbankfeld pfad_dp der Pfad stehen, wo die Stammdaten zu finden sind. Z. B. F:\waage.

Werden beim Programmstart keine Stammdateien gefunden, so kann die Datei locpara.dbf editiert werden. Falls die Datei nicht vorhanden ist, so wird Sie vom Programm aus angelegt. Die Datei locpara.dbf kann über das Programm dbu.exe oder über das Waagenprogramm Zusätze – Systemprogramme – System editiert werden. Hierbei wird erst die Datei system.dbf editiert. Nach beenden dieser Datei kann die Datei locpara.dbf editiert werden.

Das Programm, welches auch die Stammdaten enthält, sollte den Anschluß an die Waage(n) haben. Damit ist gewährleistet, daß dieses Programm auch ohne Netzwerk läuft.

Die anderen Installationen sollen oft keine Schnittstellen öffenen. Hierzu muß in der Datei system.dbf der Parameter waagenAnz auf Null geseetzt werden. Bitte beachten Sie, daß die Namen der Parameter nicht geändert werden dürfen. Nur der Wert darf entsprechend gesetzt werden.

Im Satz Auftragnr bei val die Auftragsnummer, und im Text den Kundennamen eintragen. Diese Daten werden dann in dem Programmfenster angezeigt. Änderungen in dieses Systemdateien sollten nur von eingewiesenem Personal erfolgen. Sie können hier das Programm so beeinflussen, daß ein ordentlicher Programmablauf nicht mehr gewährleistet ist. Nachdem Sie die Änderungen in den Dateien gemacht haben, muß das Programm neu gestartet werden.

Die Daten für Länge der Stammdatennummern können ebenfalls in der Datei system.dbf eingetragen werden. W

ACHTUNG: Diese Daten müssen bei allen Installationen gleich sein., und dürfen im laufenden Betrieb nicht geändert werden. Bei Änderungen können Sie anschließend nicht mehr auf Ihre bisherigen Stammdaten zugreifen.

Falls die Anzahl der Waagen auf 0 gesetzt sind, so müssen die Schnittstellen alle auf .f. gesetzt werden.

Parameterdatei - SYSTEM. (Hiermit wird die Datei comdat.dbf editiert).

Nachdem alle Werte richtig eingetragen wurden, muß das Programm neu gestartet werden. Jetzt kann auf die entfernten Stammdaten zugegrifffen werden.

Passwort ist 170424, bei 2facher Abfrage nur 17, bei 8facher 17042417.

Parametrierung der Schnittstellen:

Im Menue Parameter – System werden die Schnittstellen eingestellt. Als Waagentyp sind folgende Parameter vorhanden:

Typ

PRN Drucker, wenn die Bezeichnung LSX-Drucker ist, so kann der Standarddrucker für Lieferscheine gesetzt werden. (X steht für den Lieferscheinkreis LS1-Drucker somit für den Lieferscheinkreis 1, LS2-Drucker für den 1. zusätzlichen Lieferscheinkreis). Im Feld Anschluss muss LPT1, LPT2, LPT3, LPT4 oder LPT5 für direkten Druck auf die LPT-Schnittstelle. Bei Eintrag WIN im Feld Anschluss wird über den Windowsdrucker gedruckt. In diesem Fall muß der Druckername im Feld DRUCKERNAM eingetragen werden. .

B??? Ein B auf den linken Seite kennzeichnet eine Bandwaage. Bei Bandwaagen wird auf dem LS nur das Nettogewicht gedruckt, und das Gewicht gemäß Bandwaagenprotokoll erwartet. Die restlichen Zeichen sind beliebig.

GK?? Auswerteelektronik Typ GK, d. h. statt STX?ETX wird nur ? geschickt.

F??? Kennzeichnet eine Fahrzeugwaage. Das Gewicht wird gemäß Fahrzeugwaagenprotokoll erwartet. Auf dem Lieferschein wird Brutto- Tara- und das Nettogewicht gedruckt. (Sofern Mengeneinheit T oder Blank)

KLE Kennzeichnet einen Kartenleser. Typ wird Programmintern unterschieden. Ebenso der Ablauf vom Programm.

VW Kennzeichnet eine Verbundwaage. Über der Verbundwaage müssen die beiden Einzelwaagen angegeben sein. Diese werden als normale Fahrzeugwaagen eingetragen.

PFIS Wägeterminal Fa. Pfister mit ENQ-Protokoll. Hier wird die Protokollnummer ebenfalls mit gedruckt.

Baudrate, Port und Adressen werden jeweils je Schnittstelle eingegeben. Benutzten mehrere Geräte die selbe Schnittstelle, so müssen bei allen Geräten die gleichen Schnittstellenparameter eingegeben werden.

Bei den Schnittstellen werden die Einstellungen für Adresse und Interrupt ignoriert. Hier müssen keine Daten eingetragen werden.

Bei den Fahrzeugwaagen und Bandwaagen kann ein Protokolldruck ein/ausgeschaltet werden.

Im Feld Kennung TBP eintragen, so werden für die Taraverwiegung und die Bruttoverwiegung ein Protokoll ausgedruckt. Wird nur ein P eingetragen, so wird bei der Ausgangswiegung ein Protokoll gedruckt.

Drucken von Lieferscheinen

Lieferschein können entweder direkt auf die Druckerschnittstelle gedruckt werden (für Nadeldrucker ohne Windowstreiber), oder über den Windows Standarddrucker. In der Parameterdatei – System müssen die Drucker mit Namen LSX-Drucker angelegt sein. X ist die Nummer des Druckerkreises. Die 3 unterschiedlichen Druckerkreise können auf unterschiedlichen Druckern ausgegeben werden. LS3-Drucker ist für den 2. zusätzlichen Lieferscheinkreis.

Steuerzeichen bei Nadeldruckern über LPT

Im Feld Steuerzeich.TEXT können Steuerzeichen eingegeben werden. Die Steuerzeichen sind als Dezimalzahl einzugeben. Vor jedem Steuerzeichen ist als Kennzeichnung ein & Zeichen einzugeben. Möchten Sie z. B. die Steuerzeichen CR LF eingeben so sieht der String foglendermaßen aus: &10&13. Als Steuerzeichen sind &1 bis &255 möglich. Steuerzeichen werden benutzt, um z. B. die Schriftart zu ändern, oder um einen Barcodedruck auszulösen. Weiter Unterlagen über Steuerzeichen können Sie dem Druckerhandbuch entnehmen. Falls Sie über Windowstreiber drucken, so werden keine Steuerzeichen gedruckt. Beim Probedruck auf den Bildschirm werden ebenfalls keine Steuerzeichen angezeigt.

Einstellung für Windowsdrucker

Wenn über Windowstreiber mit Nadeldrucker gedruckt wird, so ist folgendes zu beachten.

OKI-Drucker müssen auf Epson Emulation eingestellt sein. In Windows muss der Druckertreiber für EPSON FX850 verwendet werden. Für diesen Drucker muss dann das entsprechende Lieferscheinformular eingegeben werden. Über Systemsteuerung – Drucker den Drucker installieren. Nach der Installation den Drucker anklicken, so dass dieser blau unterlegt ist. Nun über Datei – Servereigenschaften ein neues Formular anlegen. Bei den Standardlieferscheinen ist dies 8,5 Zoll breit und 8 Zoll hoch. Die Eingaben müssen in Zoll erfolgen. Das Fomular MUSS unter dem Namen Lieferschein abgespeichert werden. Dieses Formular wird vom Waagenprogramm automatisch verwendet.

Anschließend müssen Sie das angelegte Formular überprüfen. Hierzu gehen Sie in die Druckereigenschaften. Unter Geräteeinstellungen muss nun das neue Formular „Lieferschein“ verfügbar sein.

Im Lieferscheinformular müssen Sie anschließend das Feld BITMAP anlegen. Dieses Feld wird über Zeile / Spalte positioniert. Die Größe der Bitmap legen Sie dann mit Länge (von Zeichen) und Breite (bis Zeichen) fest.

Optionen für GyroData

Ø Schneidedrucker / Laserdrucker für die Lieferscheinerstellung.

Ø Elektronisches Unterschriftenpad für die Erfassung der Unterschrift von Wiegemeister und Fahrer.

Ø Berührungslose Kartenleser für die Identifikation für Verladung und Verwiegung.

Ø Kontakte für Tor / Schranke öffnen.

Ø Fernwartung und Fernbedienung.

Ø Automatische Lieferscheinerstellung über externen Kontakt.

Ø Serielle Schnittstellen über Ethernet.

Ø TCP/IP Verbindung zu externen Modulen (Socketverbindung)

Ø Kamera für die Speicherung eines Bildes zum Lieferschein.

Ø Programm in deutsch, englisch und französisch verfügbar.

Ø Fernbedienung über GCU64 (Wägeterminal)

Ø Lieferscheindruck über ACCESS möglich.

Ø Lieferschein als PDF-Datei erstellen und per eMail versenden.

Ø Anbindung an bauseitigen SQL-Server (ODBC) für Datenaustausch.

Ø Programmierung von kundenspezifischen Anforderungen

Kundenspezifische Ergängzungen:

Die folgenden Blätter sind für die Kurzbeschreibung von kundenspezifischen Programmänderungen vorgesehen. Diese (von Kunden gewünschte Änderungen) sind von Programm zu Programm unterschiedlich.